SoftChalk

Level 1
University Information Technology Services

SoftChalk: Level 1

Table of Contents

Introduction ...................................................................................................................................... 5
Learning Objectives ........................................................................................................................ 5
FERPA ............................................................................................................................................... 5
Installing SoftChalk ........................................................................................................................... 6
Getting to Know SoftChalk ................................................................................................................ 6
    Tools and Menus .......................................................................................................................... 6
SoftChalk User Guide ........................................................................................................................ 8
Saving Your Lesson ............................................................................................................................ 8
Add Text to Your Lesson ....................................................................................................................... 9
    Pasting Text ........................................................................................................................................................ 9
    Formatting Text ................................................................................................................................................. 9
    Adding Special Characters .................................................................................................................... 10
    Check Spelling ............................................................................................................................................ 10
Define Headings in your Text ............................................................................................................ 11
Create a Multi-page Lesson ............................................................................................................... 11
    Add a Page Break ......................................................................................................................................... 11
    Removing a Page Break .......................................................................................................................... 12
Add a List to your Lesson .................................................................................................................... 12
    Bulleted lists ................................................................................................................................................ 12
    Numbered Lists ........................................................................................................................................... 14
Insert a Hyperlink ............................................................................................................................. 14
Internal Links (Bookmarks) ................................................................................................................. 15
    Insert the Bookmark .................................................................................................................................. 16
    Link to the Bookmark ............................................................................................................................ 16
    Modify or Remove a Bookmark ............................................................................................................. 17
Insert a PDF ..................................................................................................................................... 17
<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Insert an Image</td>
<td>18</td>
</tr>
<tr>
<td>Image File Types</td>
<td>18</td>
</tr>
<tr>
<td>Reduce your Image Size</td>
<td>19</td>
</tr>
<tr>
<td>Space around an Image</td>
<td>20</td>
</tr>
<tr>
<td>Align your Image</td>
<td>21</td>
</tr>
<tr>
<td>Accessibility Items</td>
<td>21</td>
</tr>
<tr>
<td>Re-size an Image within the Main Editing Window</td>
<td>21</td>
</tr>
<tr>
<td>Wrap Text around an Image</td>
<td>22</td>
</tr>
<tr>
<td>Remove an Image</td>
<td>22</td>
</tr>
<tr>
<td>Insert a TextPopper</td>
<td>23</td>
</tr>
<tr>
<td>Removing or modifying a TextPopper</td>
<td>24</td>
</tr>
<tr>
<td>Insert Audio</td>
<td>24</td>
</tr>
<tr>
<td>Remove Audio</td>
<td>26</td>
</tr>
<tr>
<td>Embed a YouTube Video</td>
<td>26</td>
</tr>
<tr>
<td>Style a Lesson</td>
<td>29</td>
</tr>
<tr>
<td>Attach a Style</td>
<td>30</td>
</tr>
<tr>
<td>Set Options for Your Style on the Title &amp; Layout Tab</td>
<td>31</td>
</tr>
<tr>
<td>Sidebars</td>
<td>34</td>
</tr>
<tr>
<td>Insert an Image in a Sidebar</td>
<td>36</td>
</tr>
<tr>
<td>Table of Contents</td>
<td>37</td>
</tr>
<tr>
<td>Table of Contents Page</td>
<td>37</td>
</tr>
<tr>
<td>Rollover menu in a sidebar</td>
<td>37</td>
</tr>
<tr>
<td>Dropdown Menu at Top of Page</td>
<td>38</td>
</tr>
<tr>
<td>Add Page Names for the Table of Contents</td>
<td>38</td>
</tr>
<tr>
<td>Publishing your Lesson to Desire2Learn</td>
<td>39</td>
</tr>
<tr>
<td>Step 1 – Sign in to SoftChalk Cloud</td>
<td>39</td>
</tr>
<tr>
<td>Step 2 – Publish to the Cloud</td>
<td>40</td>
</tr>
<tr>
<td>Step 3 – Copy the Cloud URL</td>
<td>41</td>
</tr>
<tr>
<td>Step 4 – Create a Quicklink in D2L</td>
<td>43</td>
</tr>
<tr>
<td>Viewing your SoftChalk Lesson in D2L</td>
<td>44</td>
</tr>
<tr>
<td>Editing a Lesson after Saving to the SoftChalk Cloud</td>
<td>45</td>
</tr>
<tr>
<td>Option 1 – Editing your Lesson in SoftChalk Create 8</td>
<td>45</td>
</tr>
<tr>
<td>Option 2 – Editing your Lesson from the SoftChalkCloud.com Website</td>
<td>45</td>
</tr>
<tr>
<td>Additional Support</td>
<td>49</td>
</tr>
</tbody>
</table>
Introduction

SoftChalk® Create version 8 is a stand-alone application that lets you create lessons to publish online. Lessons can include text, multimedia, self-check quizzes, and more. Your lessons can include multiple linked pages and a table of contents, and you can style your lessons for a professional look. Kennesaw State University also has licenses for the SoftChalk Cloud, which allows you to easily make changes to your existing lessons.

After you build your lesson in SoftChalk and save it to the SoftChalk Cloud, you can link it into Desire2Learn to share it with your students. Your lesson is compatible with the following standard Web browsers: Internet Explorer®, Firefox®, and Safari®. The SoftChalk application is available for both Windows® PCs and Macs®. This booklet uses the Windows version of the application for all examples, but the Mac version is similar.

Learning Objectives

After following this document, you should be able to perform the following actions in SoftChalk:

- Create and save a new lesson
- Open saved lessons
- Add text to your lesson
- Add links to your lesson
- Add multimedia objects to your lesson, including:
  - Images
  - Audio
  - YouTube videos
- Change the style of your lesson
- Add sidebars and a Table of Contents to your lesson
- Save your lesson to the SoftChalk Cloud
- Link your lesson into Desire2Learn
- Edit your lessons from the SoftChalk Cloud

FERPA

Any student data is protected by FERPA regulation. This includes any SoftChalk activities and quizzes that generate student grade data. If you have any questions about FERPA, please refer to KSU’s online FERPA training at https://campustraining.kennesaw.edu/course/view.php?id=46
Installing SoftChalk

SoftChalk Create 8 can be installed on a PC or a Mac by visiting KSU’s Software Downloads page at [https://uits.kennesaw.edu/downloads/](https://uits.kennesaw.edu/downloads/). Note that the Soft Chalk End User License Agreement specifies use for the support of distance learning (online and hybrid courses and administration).

Contact the KSU Service Desk at 470-578-6999 for assistance installing SoftChalk.

Getting to Know SoftChalk

After installing SoftChalk, launch it from the shortcut on your desktop or from your Start menu.

![SoftChalk shortcut](image)

When you start SoftChalk, you automatically receive a blank, untitled lesson (Figure 1).

![Blank, untitled lesson](image)

Figure 1. Blank, untitled lesson.

Tools and Menus

SoftChalk has several menus that you will use to create your lessons.

Top Menu Bar:
The top menu is a set of dropdown menus (Figure 2). It houses many of the functions available to you in SoftChalk.
Figure 2. Top menu bar.

**Toolbar:**
The toolbar contains many tools that you’ll want to access quickly (Figure 3). Most toolbar items relate to text formatting, plus other content like Images and Links.

Figure 3. Toolbar.

**Main Editing Window:**
The main editing window is where you will create your content in SoftChalk (Figure 4).

Figure 4. Main editing window.
SoftChalk User Guide

In addition to the training resources offered by ITS Outreach and Distance Learning Technologies, you can also access an extensive User Guide directly from SoftChalk. Within SoftChalk, click the Help menu ➔ Help Topics ➔ User Guide (pdf) (Figure 5).

Figure 5. User Guide (pdf).

Under the Help ➔ Help Topics menu, you can also access FAQs, a video tour, and sample lessons. These items will open the SoftChalk Website in your default browser.

Saving Your Lesson

To save your new lesson, follow the instructions below.

1. Go to File in the top menu bar.
2. Click Save As.
3. The Save dialog box will open (Figure 6).

Figure 6. Save dialog box.

4. Browse to the desired location, such as Documents.
5. Enter an appropriate File Name.
6. Click Save.

Now that your project has been saved the first time, you can simply click File ➔ Save in the future.

When you save your lesson, it becomes a folder with various files in it. Fortunately, you don’t need to know the function of these files. After you create your lesson, you will upload it to the SoftChalk Cloud.

Add Text to Your Lesson

To add text to your lesson, simply begin typing in the main editing window (Figure 7). You can also paste in text from another source, such as Microsoft Word ®.

![Figure 7. Adding text to your lesson.](image)

Pasting Text

You can use the Copy/Paste function to paste text from any source (such as Microsoft Word or Internet Explorer). However, pasted text retains its original formatting. You may have trouble formatting text you have pasted to match the rest of your lesson.

Using the Paste as Plain Text function alleviates this issue, as explained in the following steps.

1. Copy text from the source location (such as Word).
2. In SoftChalk, place your cursor where you want the pasted text to appear.
3. Click Edit ➔ Paste as Plain Text.
4. Your text is pasted without formatting. You can now format the text as needed.

Formatting Text

You can format your text using the tools in the Toolbar.

1. Highlight the text you want to format.
2. Make one or more selections in the toolbar, such as bold, italics, or color (Figure 8).

![Figure 8. Formatting your text with the Toolbar.](image)

Adding Special Characters
You can insert special characters, such as the copyright mark or accented letters.

![Figure 9. Inserting Special Characters.](image)

1. Place your cursor where the special character should go.
2. Click the **Insert** menu ➔ **Special Characters** (Figure 9).
3. Some characters are listed here. Choose one of the characters that appears, or click **Other**...
4. Select the character(s) you need to use.
5. Click **Close**.

Check Spelling
To check spelling, click **Tools** ➔ **Check Spelling**.
NOTE: SoftChalk does NOT notify you of misspellings as you type. You must run the spell check tool.

Define Headings in your Text

As you enter the text for your lesson, you should define headings where appropriate. This will help build the navigation of your lesson later, when you add a Table of Contents and/or Sidebars.

![Figure 10. Defining a heading.](image)

1. Highlight the text that should be a heading.
2. Select **Heading 1**, **2**, or **3** from the dropdown at the far right of the Toolbar (Figure 10).

NOTE: Heading 1 is the highest level; heading 2 is a subheading beneath heading 1, and so on.

You can change the formatting of your headings later; see the **Styles** section.

Create a Multi-page Lesson

To create lessons with multiple pages, you’ll insert page breaks to create pages. There is no limit to the number of pages you can create. However, 3–20 pages is the recommended range.

Add a Page Break

Type or paste your text in the main editing window. When you’re ready to move to a new topic or a different “chunk” of information, follow these steps to insert a page break.

1. Place your cursor where you want a new page to begin.
2. Choose **Insert → Page Break → Insert** (Figure 11).
Figure 11. Inserting a page break.

You’ll see a dotted blue line, which represents your page break. You can now continue entering text and content, either above or below your page break.

**Removing a Page Break**

If you need to remove a page break, follow these steps.

1. Right-click on the page break (Figure 12).
2. Select **Remove Page Break**.

Figure 12. Remove Page Break.

**Add a List to your Lesson**

Lists add organization to your lesson and make information easy to understand.

**Bulleted lists**

To add a bulleted list, follow these steps.
Figure 13. Bulleted lists.

1. Click the **Toggle Bullet List** button to begin your first bulleted item (Figure 13).
2. Type the list item.
3. Hit the **Enter key** on your keyboard; your next bullet automatically appears.
4. To indent a bullet item, click the **Increase Indent** button.
5. Your list items will continue at the indented level until you change it again, via the **Increase Indent** or **Decrease Indent** buttons.
6. When you have entered your last list item, hit the **Enter** key again.
7. You will receive another bullet automatically. Click the **Toggle Bullet List** button to turn off the bullet formatting; the bullet on your last line is removed.
Numbered Lists
To add a numbered list, follow these steps.

1. Click the **Toggle Number List** button to begin your first numbered item (Figure 14).
2. Type the list item.
3. Hit the **Enter** key on your keyboard; the next number automatically appears.
4. To indent a list item, click the **Increase Indent** button.
5. Your list items will continue at the indented level until you change it again, via the **Increase Indent** or **Decrease Indent** buttons.
6. When you have entered your last list item, hit the **Enter** key again.
7. You will receive another number automatically. Click the **Toggle Number List** button to turn off the list formatting; the number on your last line is removed.

Insert a Hyperlink
You can use hyperlinks within your SoftChalk lesson to direct your students to other online resources. Follow these instructions to insert a hyperlink in your lesson.

1. Use your mouse to highlight the text that will become your link.
2. Choose the **Insert Hyperlink** icon on the toolbar (Figure 15).

Figure 14. Numbered lists.

Figure 15. Insert hyperlink.
3. The *Insert a Hyperlink* dialog box will open (Figure 16).

![Insert A HyperLink](image)

Figure 16. Insert a Hyperlink dialog box.

4. Within the *URL or Selected File* box, type the URL or use Ctrl+V to paste your URL.
5. The *Open the link in a new window* option is selected by default. This means your students can click links without leaving your lesson.
6. Click **OK**.
7. The linked text is now underlined and blue to indicate the hyperlink.

To remove a hyperlink, follow these steps.

1. Right-click on the hyperlink and choose **Modify Hyperlink**.
2. Click **Remove**.
3. Click **OK** to return to your main editing window.

**Internal Links (Bookmarks)**

You can create a link from one part of your lesson to another. For instance, you may be on page 5 of your lesson and want to refer back to information on page 2. In this case, you create a bookmark on page 2, then insert a link to that bookmark on page 5. See the steps below for details.
Insert the Bookmark
These steps explain how to create a bookmark inside your lesson.

1. Click where you want your bookmark to go. (If you select text, the bookmark will be placed before the first character of your selected text.)
2. Choose Insert ➔ Bookmark.
3. Type a name for your bookmark.
4. Click OK to return to your main editing window.
5. Notice the bookmark icon in your lesson.

NOTE: The bookmark icon is only visible for you in the SoftChalk editing window. It will not be displayed in your published lesson.

Link to the Bookmark
These steps explain how to link to the bookmark that you created above.

1. Select the text that will become your link.
2. Choose Insert ➔ Hyperlink.
3. The Insert a Hyperlink dialog box will open (Figure 17).

![Insert A Hyperlink dialog box]

Figure 17. Link to internal bookmark.
4. Select **Choose Bookmark**.
5. From the dropdown menu, select your bookmark.
6. Click **OK** to return to your main editing window.

**Modify or Remove a Bookmark**
1. Right-click on the bookmark icon in your lesson.
2. Choose **Modify Bookmark** or **Remove Bookmark**.

**Insert a PDF**
In addition to inserting hyperlinks to Web pages, you can add a hyperlink to a file you have saved, such as a PDF.

1. Make sure the file (e.g., PDF) is saved to your computer, to a location such as *My Documents*.
2. In SoftChalk, type the text that your students will click to open the hyperlink (for instance, the name of the PDF article).
3. Highlight the text that will become the hyperlink.
4. Choose **Insert → Hyperlink**.
5. The **Insert a Hyperlink** dialog box will open (Figure 18).

![Insert A Hyperlink](image)

**Figure 18. Hyperlink to a file.**
6. Click **Select File**.
7. Browse to the file (PDF) on your computer and select it. Then, click **Open**.
8. Click **OK**.

Your file is now hyperlinked in the lesson, and a copy of the file has been placed in your lesson folder.

**NOTE:** Remember that adding many large files will make your lesson folder larger as well. However, you can add hyperlinks to Web resources without making your lesson folder any larger.

**Insert an Image**
Images add interest to your lesson. You can easily insert images throughout your lesson in SoftChalk.

**NOTE:** When you insert an image, a copy of the image is placed in your lesson folder. Your original image remains untouched in its original location.

**Image File Types**
You can insert a file that is a .jpg, jpeg, .gif, .png or a .bmp. You can’t insert a .tif file.

To insert your image file, follow these steps.

1. Place your cursor where you want your image to appear in the lesson.
2. Click the **Insert Image** icon in the toolbar (Figure 19).
3. Click the **Select Image** button.
4. The **Select Image** browser window will open. Browse to find your image file, then click to select your image file.

**NOTE:** If you have issues linking to your file, check to see if you have unusual characters in your file name such as a period, & or # sign. SoftChalk only recognizes letters, numbers, dashes, and underscores. You may have to rename your image file.

5. Click **Select**.
6. You have several options for image attributes, which are described individually in the upcoming sections.
7. Click **OK** when you are done setting your image attributes.

**Reduce your Image Size**

When inserting your image, notice the colored dot indicating whether your file size is acceptable.

![Image Size Example](image.png)

**Figure 20.** "Good" image size.

A green dot indicates a good image size, as in the example above (Figure 20).

![Image Size Example](image2.png)

**Figure 21.** "Not recommended" image size.

A red dot indicates an image that is too large, as in the second example (Figure 21).
NOTE: Too many images with large file sizes in your lesson may cause your pages to load slowly in the Web browser. See the following steps to learn how to reduce your image size.

If you click the Optimize Image button, shown in Figure 24, notice the changes below:

- The green dot Good appears now.
- Your original image (outside your lesson folder) remains unchanged when you click Optimize Image. Only the image inserted in your lesson is resized.

Notice that the image may still be large in size. If you have a lot of images in a lesson, you may want to use an image editing program [such as Microsoft Office Picture Manager] to reduce the size or dimensions of your image even more.

Space around an Image
From the Insert Image dialog box, notice that you can add vertical space (V space) or horizontal space (H space) in pixels (Figure 22). Use this option if the image is left or right aligned and there are bullets in the text next to the image.

Figure 22. Image attribute options.
If you do not specify a value for V space or H space, there will be no padding (blank space) around the image.

**Align your Image**
Choose an Align option from the *Insert Image* dialog box. You can select from the following options:

- None (placed where your cursor is)
- Left
- Right
- Top
- Absbottom

Absbottom means absolute bottom. This option may be helpful for math equations.

**Accessibility Items**
Complete the *Alternative text* and *Long Description* text boxes in the *Insert Image* dialog box to provide an alternate to viewing the image. For more information about SoftChalk’s Accessibility compliance, see [http://www.softchalk.com/lb_standards.html](http://www.softchalk.com/lb_standards.html).

**Re-size an Image within the Main Editing Window**
You can resize your image from the main editing window with the following steps.

1. Within your main editing window, click on your image to select it.
2. Drag a corner square handle to re-size it proportionally (Figure 23).
Wrap Text around an Image

SoftChalk can wrap your lesson text around the images you insert. The following steps explain how to set text wrapping for an image.

1. Right-click on the image you have already inserted.
2. Click Modify Image.
3. For the Align option, select Left or Right.
4. Click OK to return to your main editing window, and you can see the text wrapping (Figure 24).
5. Adjust the size of your image as needed.

![Figure 24. Image with text wrapping.](image)

Remove an Image

Follow these steps to remove an image from your lesson.

1. Within your main editing window, right-click on an image.
2. Choose Modify Image.
3. Click Remove.
4. Click OK to return to your main editing window.

**NOTE:** When you remove an image, the file remains in your lesson folder. Outside of SoftChalk, delete the extra image manually from your lesson folder.
If you don’t delete the image from your lesson folder, your students won’t see the removed image. However, your lesson may become large if you have a lot of removed images still in your lesson folder. Your lesson may load slowly in the Web browser.

Another option to handle removed images is to use Save As. Within SoftChalk, you can choose **File → Save As** and give your lesson a different name. When you choose Save As, SoftChalk saves only the current images for the lesson. IMPORTANT: Be careful where you save your lesson. You do not want to save your renamed lesson within your current lesson folder.

### Insert a TextPopper

A **TextPopper** is a text annotation that will appear in your lesson when the cursor hovers over a designated word or picture.

1. Select the text or image that should trigger the TextPopper.
2. Click **Insert → TextPopper**.
3. The **TextPopper** dialog box will open (Figure 25).

![TextPopper dialog box](Image)

**Figure 25.** TextPopper options.
4. Add text to the Top Area, optional.
5. Add text to the Bottom Area, required.
6. Choose a Background Style. The default is called Original; the preview shows a purple color, but the color of the final TextPopper will match your lesson’s Style. (Styles are explained later in this document.) You can choose any of the eight TextPopper style options.
7. Click OK.

The TextPopper will not be visible in your main editing window. Choose Preview → View in Browser to preview your lesson in the browser, where you can test your TextPopper (Figure 26).

Insert Audio

You can insert an audio file into your lesson with the following steps. SoftChalk supports many audio file types, including mp3, wma, and wav files.

1. Place your cursor where you want the audio icon to appear.
2. Choose **Insert → Media**.

3. The *Insert Media* dialog box will open (Figure 27).

![Figure 27. Insert audio file.](image)

4. Select the **Audio** file type.

5. Click the **Select File** button.

6. The *Select Audio File* browser window will open (Figure 28).

![Figure 28. Select Audio File browser window.](image)
7. Browse to the audio file on your computer and select it.
8. Click the **Select** button.
9. Choose whether you wish to *Insert As: Linked File* or *Inline Player* (explained below).
   a. The *Linked File* will show a small speaker icon in your lesson (Figure 29). When students click it, the audio file will automatically open outside the lesson, in their computer’s default audio player (such as Windows Media Player or iTunes). **Recommended**

![Figure 29. Example of Linked audio file.](image)

b. The *Inline Player* allows your students to play your audio file inside the lesson by clicking the *Play* arrow on the player (Figure 30).

![Figure 30. Example of Inline audio player.](image)

d. Click **OK**.
10. You have successfully inserted an audio file in your lesson.

**Remove Audio**
To remove the audio file, follow these steps.

1. Right-click on the audio icon or inline audio placeholder.
2. Choose **Modify Media**.
3. Click the **Remove** button.

**Embed a YouTube Video**
You can embed a YouTube video in your lesson using a *Widget*.

1. In SoftChalk, place your cursor where you want the video to appear in your lesson.
2. Choose **Insert → Widget**.

3. The *Insert Widget* dialog box will open (Figure 31).

![Insert Widget dialog box](image)

**Figure 31.** Adding a YouTube video Widget.

4. Enter a name for your Widget (such as the topic of the video).

5. Next, you need to add the HTML code for the YouTube video. Leave SoftChalk open while you complete these steps:
   
a. Open your Web browser, such as Internet Explorer.
   b. Browse to the desired video on [www.YouTube.com](http://www.youtube.com)
c. **Click the Share button beneath the video** (Figure 32).

![Figure 32. Share button on YouTube.](image)

**Figure 32. Share button on YouTube.**

**Figure 33. Embed code from YouTube.**
d. Click the Embed button that appears (Figure 33).
e. Choose the desired size for the video, as it will appear in your lesson.

**NOTE:** The recommended size is 640 x 360 or similar.

f. Check the box for Use HTTPS.
g. Copy the Embed Code (which begins with <iframe width...) from YouTube.

7. Paste the code in the Widget HTML box using the Paste HTML button (Figure 34).

![Figure 34. Insert Widget with code added.](image)

8. Click OK.

The YouTube video is now embedded in your lesson. In the main editing window, you will see only a gray box called Widget Placeholder.

**NOTE:** The video will not appear when you preview your lesson in browser. However, it will display once you upload your lesson to the SoftChalk Cloud and/or Desire2Learn.

**Style a Lesson**

Without a style, your lesson looks plain in a Web browser, similar to the way it looks during editing in SoftChalk. There is no header, footer, or sidebars; there are simple navigation links (previous page | next page) at the bottom of a page.
When you attach a style to your lesson, your lesson automatically acquires a professional appearance with a header (also referred to as a banner), footer, navigation bar, and options for sidebars.

### Attach a Style

Follow these steps to attach an existing style to your lesson.

1. **Choose Properties → Style Properties** (Figure 35).

![Figure 35. Style Properties menu.](image)

2. **The Style Properties window will open** (Figure 36).

![Figure 36. The Style Properties window.](image)
3. Click on a style in the right panel, under *Style Choices*. Notice that you can scroll down to view even more styles.

4. When you click on a style, you’ll see a larger preview of the style in the left panel, under *Selected Style*.

5. When you have found a style you like, click **OK**.

Now that you have applied a style, some items will be changed in your SoftChalk main editing window. For instance, the formatting of your Headings will be styled.

To see the full effect of the style, though, view the preview of your lesson in your Web browser. Click **Preview → View in Browser** (Figure 37). You may be prompted to save your lesson; click **Yes**.

![Figure 37. Preview in Browser.](image)

If you preview your lesson at this point, you’ll see a header with no text, a footer with some default text and a navigation bar at the top if you have inserted some page breaks. (These “style” items don’t appear when you’re looking at your lesson in SoftChalk.)

You can add more options to your lesson in the upcoming sections of this booklet.

**Set Options for Your Style on the Title & Layout Tab**

Follow these steps to set important Style Options for your lesson.

1. Choose **Properties → Style Properties**.
2. Click the **Title & Layout** tab (Figure 38).
3. **Lesson Title**: The *Lesson Title* and *Subtitle* appear in the header in a Web browser. The header appears the same on all pages of your lesson. Entering a title is recommended (Figure 39).

![Lesson Title](image)

**Figure 39. Lesson title and subtitle.**

4. **Footer - License**: Under the License dropdown menu, you can select an *Attribution* for Creative Commons licensing (Figure 40).
a. A Creative Commons license maintains your copyright of your own work, but allows others to copy your work if they give you credit. Read more at http://creativecommons.org/choose/

b. When you preview your lesson, a CC icon shows up in the footer indicating an Attribution. Each Attribution option links to a different license.

5. Footer - Text: Like the header, the footer will appear the same on every page when viewing the lesson in a Web browser (Figure 41).

a. The default footer text is Created with SoftChalk. You can enter any text you like here.

b. Right-click within the Footer Text area and notice that you can add an Image, Hyperlink, Widget or Special Characters.

6. Sidebar Layout: You can choose to have your sidebar on the left or right of your page. For details, see the section Sidebars.

7. Table of Contents: For details on setting up a Table of Contents, see the section Table of Contents.

8. Navigation:
   o Arrows—When selected, the Prev (Previous) and Next arrows appear in the navigation bar at the top in the Web browser.
   o Page Numbers—When selected, numbers for the pages appear in the navigation bar at the top in the Web browser.
- **“On This Page” sidebar**—When selected, a sidebar appears in the Web browser with links to the headings (Heading 1, Heading 2, Heading 3) on the page (see Sidebars).

9. **Print all pages**: When selected, a print all button appears in your published lesson, allowing your students to print all the pages of your lesson.

After choosing your settings, remember to use Preview to see the fully-styled lesson in a Web browser.

**Sidebars**

Sidebars can be displayed on the left or right of one or more pages of your lesson. You may use them for navigation in the lesson, or for extra content.

Some Sidebar settings, such as location (left or right) and the “On This Page” sidebar (Figure 42), are configured in **Style Properties → Title & Layout** tab (as described in the previous section).

![On This Page sidebar](image)

Figure 42. On This Page sidebar.

**NOTE**: The **On This Page** sidebar uses your defined Headings (Heading 1, 2, and 3). It will only appear if you have **more than one** heading defined on the page.

Other side bar options are available in the following steps.

1. Choose **Properties → Sidebars** (Figure 43).

![Sidebars](image)

Figure 43. Sidebars.

2. Choose a sidebar type: Handouts, Learn More, More Resources, or Text Only.
NOTE: The only difference in the functionality among the Handouts, Learn More, More Resources and Text Only sidebars is the title for the sidebar. You can put your own title in the Text Only sidebar.

3. When you have chosen a Sidebar type, the Sidebar window will open (Figure 44).

![Sidebar window](image)

**Figure 44.** Sidebar window.

4. Add a *Title* for your sidebar. (This is only necessary for the Text Only sidebar type.)
5. Type your text for the sidebar.
6. You can add other content, such as Images, Hyperlinks, or Bulleted lists, by right-clicking in the text area.
7. If you want this sidebar on only one page of your lesson, use the *For Page* dropdown to choose the appropriate page number.
8. If you want this sidebar to appear on all pages of your lesson, click the Copy To All Pages button.
9. Click OK when you are done.

NOTE: As you add sidebars, remember that you won’t see the sidebars within your main editing window. You will see them when previewing the lesson in the Web browser.
Insert an Image in a Sidebar
To insert an image in your sidebar, follow these steps.

1. Right-click in the text editing area of the sidebar editing window (Figure 45).

![Figure 45. Inserting an image in a sidebar.]

2. Choose **Image** from the menu that appears.
3. The **Insert Image** window opens.
4. Click the **Select Image** button.
5. Browse to the image file on your computer and select it. Click the **Select** button.

**NOTE:** Maximum recommended width is 145 pixels. A larger image will not fit properly in the sidebar.

6. In the **Change Width** field, enter a width of 145. The height will adjust automatically.
7. Click **OK**.
8. Click **OK**.

The image is now inserted in your sidebar.
Table of Contents

For your Table of Contents, you can choose from three options. All the options are available as checkboxes in Properties → Style Properties → Title & Layout tab. You can choose more than one.

**NOTE:** The Table of Contents pages, menus, and sidebars are only visible in your Preview or published lesson; you will not see them in the SoftChalk main editing window.

Table of Contents Page

To add a *Table of Contents* page as seen in Figure 46, complete the following steps.

1. Click Properties → Style Properties → Title & Layout tab.
2. Check the box for *Table of Contents page*.
3. Click OK.

![Figure 46. Preview of Table of Contents page in a Web browser.](image)

Rollover menu in a sidebar

You can also add an interactive Table of Contents rollover menu to your sidebar (Figure 47) with the following steps.

1. Click Properties → Style Properties → Title & Layout tab.
2. Check the box for *Rollover menu in sidebar*.
3. Click OK.
Figure 47. Preview of rollover menu in sidebar.

**Dropdown Menu at Top of Page**

You can also add an interactive Table of Contents dropdown menu to the top of your lesson (Figure 48) with the following steps.

1. Click **Properties → Style Properties → Title & Layout**.
2. Check the box for **Dropdown menu at top of page**.
3. Click **OK**.

Figure 48. Preview of dropdown menu at top of page.

**Add Page Names for the Table of Contents**

If you are using a Table of Contents, you may want to define **Page Names**. If you do not define page names, the pages will be displayed as **Page 1, Page 2, etc.**
1. Click Properties → Page Names.
2. The *Page Names* dialog box will open (Figure 49).

   ![Page Names dialog box](image)

   **Figure 49.** Page names.

3. Type your page names.
4. Click OK.

**NOTE:** SoftChalk will automatically allow you to name as many pages as you have currently created. If you add more page breaks later, you can come back and complete the additional page names.

---

**Publishing your Lesson to Desire2Learn**

Publish your lesson to Desire2Learn using the SoftChalk Cloud. This process includes 4 steps:

- **Step 1** – Sign in to SoftChalk Cloud
- **Step 2** – Publish to the Cloud
- **Step 3** – Copy the Cloud URL
- **Step 4** – Create a Quicklink in D2L

**Step 1 – Sign in to SoftChalk Cloud**

Complete the following steps in the SoftChalk software.

**NOTE:** Signing into the SoftChalk Cloud is only necessary the first time you use SoftChalk on your computer.
1. Click **File** in the *SoftChalk Create 8* menu bar.
2. Click **Manage Publish Accounts**.
3. Click the **New** button.
4. At the **Account Type Selection** screen, choose **SoftChalk Cloud** and click the **OK** button.
5. Enter your **SoftChalk Cloud username** and **password**.

![Figure 50. Signing into the SoftChalk Cloud.](image)

**NOTE:** If you do not have a SoftChalk Cloud account, please submit a request to the KSU Service Desk via phone (770-423-6999) or email (service@kennesaw.edu).

6. Click the **OK** button.
7. Click the **Close** button.

**Step 2 – Publish to the Cloud**

1. Click **File** in the *SoftChalk Create 8* menu bar.
2. Click **Save to SoftChalk Cloud**.
3. The **Save To Cloud** window will open. There is a pause as SoftChalk signs into your SoftChalk Cloud account.
4. Make sure your **Lesson Title** is complete.
5. Choose **Personal** as your **Privacy setting**.
6. Click the **Save** button.
7. A progress bar appears while your lesson is being uploaded to the Cloud.
8. You will see the message, “Your lesson has been saved to SoftChalk Cloud;” click the OK button.
9. Click the Close button.

Your lesson is successfully saved to the Cloud. It is ready to be linked into Desire2Learn.

**Step 3 – Copy the Cloud URL**
1. In your browser, go to the website http://www.softchalkcloud.com
2. Click the Login link at the top right.
3. Enter your email address and password, and click the Login button.
4. In the menu bar, hover over **My Content**, and then click **My Lessons & Courses** from the menu that appears below.
5. All the lessons you have published to the Cloud appear.
6. Click the **name** of the lesson you are working on.
7. A preview of your lesson appears. **Scroll down** below the lesson.
8. Copy the URL that appears under **Hyperlink (Permalinks)**.

You have now copied the link to your lesson and are ready to paste the link into Desire2Learn.
Step 4 – Create a Quicklink in D2L

After copying your link from the SoftChalk Cloud, create a QuickLink in your course in D2L to share it with your students.

1. Log into Desire2Learn in your web browser.
2. Choose your course from the *My Courses* area.
3. Click *Content* in the top course menu.
4. Under the appropriate module, click the blue **New** button.

5. Choose the topic type **Create a Link**.

![Create a Link](image)

*Figure 54. Choosing the topic type Create a Link in Desire2Learn.*

6. Enter a **Title**.
7. Paste your copied **SoftChalk Cloud Hyperlink** into the **URL** field.

**NOTE:** In the URL field, `http://` is pre-populated. Make sure to erase or overwrite the text `http://` with your SoftChalk URL. Do not leave the extra `http://` in front of your SoftChalk URL.

![New Link](image)

*Figure 55. Completing the required fields for your new topic in Desire2Learn.*

8. Click the **Create** button.

Your SoftChalk lesson is now linked in your course Content in D2L.
Viewing your SoftChalk Lesson in D2L
To verify that your lesson is available, follow the steps below.

1. Click the **Course Home** menu item.
2. Click on the Module (folder) that contains your SoftChalk lesson.

![Figure 56. Link to the SoftChalk lesson.](image)

3. Click on the link to your SoftChalk lesson (Figure 56).
4. The lesson will be displayed in your browser (Figure 57).

![Figure 57. SoftChalk lesson displayed in a course.](image)
Editing a Lesson after Saving to the SoftChalk Cloud

Because the SoftChalk Cloud allows you to simply link a lesson into Desire2Learn, you can easily edit your lessons at any time. The update is instantly available to your students.

Option 1 – Editing your Lesson in SoftChalk Create 8

On your own computer, you can edit your SoftChalk lesson in your locally-installed SoftChalk Create 8 software.

1. Click File in the SoftChalk Create 8 menu bar.
2. Select Open from SoftChalk Cloud. *see note below
3. Browse to your lesson in your SoftChalk Cloud lessons area, and select it.
4. Click the Open button.
5. Make changes to your lesson as needed.

After you are done editing:
6. Click File in the SoftChalk Create 8 menu bar.
7. Select Save to SoftChalk Cloud.
8. Click the Save button.
9. You will receive a message, “The selected item will be replaced.” Click the OK button.
10. After your lesson uploads to the Cloud, click the Close button.

*NOTE: Choosing Open from SoftChalk Cloud instead of just Open or Open Recent is a recommended best practice, ensuring that you are editing the most recent version of your lesson. It also ensures that you save the updated lesson to the same spot in the Cloud, making your update instantly available to your students without any further action from you.

Option 2 – Editing your Lesson from the SoftChalkCloud.com Website

If you are using a computer that does not have SoftChalk Create 8 already installed, you can edit a SoftChalk Cloud lesson from the web browser. This example uses the Mozilla Firefox browser.

1. In your browser, go to the SoftChalk Cloud website: http://www.softchalkcloud.com
2. Click the Login link at the top right.
3. Enter your email address and password, and click the Login button.
4. In the menu bar, hover over My Content, and then click My Lessons & Courses from the menu that appears below.
Figure 58. Accessing your lessons from the SoftChalk Cloud website.

5. The lessons you have published to the Cloud appear.
6. Click the name of the lesson you wish to edit.
7. A preview of your lesson appears.
8. Scroll down below the lesson.

Figure 59. Edit Lesson in SoftChalk Create.

10. Your browser will prompt you to open a *.jnlp file with the Java Web Start Launcher. Click the OK button.
NOTE: If this is the first time you have edited a lesson from the SoftChalk Cloud on this computer, there is a delay of several minutes while the SoftChalk Create web-launch software is installed.

11. You will receive a Java prompt asking, “Do you want to run this application?” Click the Run button.

Figure 61. Click Run to allow SoftChalk Launch to run on your computer.
12. SoftChalk Create launches and your lesson is downloaded from the SoftChalk Cloud.
13. Make changes to your lesson as needed.

After you are done editing:
14. Click **File** in the *SoftChalk Create 8* menu bar.
15. Select **Save to SoftChalk Cloud**.
16. Click the **Save** button.
17. You will receive a message, “The selected item will be replaced.” Click the **OK** button.
18. After your lesson uploads to the Cloud, click the **Close** button.
Additional Support

For SoftChalk support, the KSU Service Desk may be contacted in the following ways:

- **Telephone for Staff**: 470-578-6999
- **Telephone for Students**: 470-578-3555
- **Email Support**: service@kennesaw.edu

Additional information about the KSU Service Desk is available at [http://uits.kennesaw.edu/servicedesk/](http://uits.kennesaw.edu/servicedesk/)